Alright I found a new proxy that works:

This one seems to have some popups (I have a massive internet blocker, so I'm not entirely sure how bad it is)

Pretty Straight forward:

Hit the link
enter the index address:
DON'T HIT GO YET! Click on options next to it and make sure scripts are enabled (Remove Scripts box unchecked, I only have Allow Cookies checked)
You should see a blue banner across (right through the damn index menu)
Hit Tab key until you get to the menu (13 Clicks of the Tab key for me)
I recommend saving the index page as a favorite to make it easier to get to

Should work fine after this let me know if it doesn't and I'll see if I can help